Ptolemy II 10.0.1 Notes for Mac OS X


Mac OS X Specific Notes

Help! I clicked on the Mac Setup file and got a strange dialog

If you get a dialog like:

setup is damaged and can't be opened. You should eject the disk image.

Then the problem is that your version of Mac OS X has a bug and needs to be reconfigured.

The bug is that the dialog should state that the dmg file is unsigned and ask you if you would like to change your settings. The file is not damaged. The bug is that the Mac operating system is incorrectly labeling the dmg as damaged because of settings in the Gatekeeper control panel.

OS X: About Gatekeeper describes how to fix Gatekeeper to allow applications downloaded from anywhere.

You are running a 1.6.0_65 version of the Java Platform

If you click on the installer and get a message that says
      The application that you are trying to install requires a 1.8 version or later of the Java platform. You are
      running a 1.6.0_65 version of the Java platform.  Please upgrade to a new version.

that looks like:

Java upgrade needed

then the problem is that you don't have a Java 1.8 JDK or JRE installed. See below for information about which Java to install.

If you do have Java 1.8 installed, then the problem could be that Java 1.6 was previously installed. See Mac: app requires Java 1.8, which is not found even though it is installed.

The workaround is to execute the installer by hand:

bash-3.2$ cd ~/Downloads/
bash-3.2$ ls
bash-3.2$ java -version
java version "1.8.0_152"
Java(TM) SE Runtime Environment (build 1.8.0_152-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.152-b16, mixed mode)
bash-3.2$ java -jar capecode0.1.devel.setup.mac.jar 
Command line arguments: 


Ptolemy II requires Java, which may be downloaded from Oracle. We suggest installing the JDK, see Note that recent versions of Mac OS X may prompt you to install the JDK if it is not yet installed.

The Ptolemy installer for Mac will install a version of Ptolemy with a JRE that includes:

  • Java 3D, which is required to run the Graphical (GR) domain demos.
  • The Java Advanced Imaging Interface.
  • The Java Serial port communication interface.
  • The Java Media Framework.

The installer requires that a Java 1.8 Java Runtime Environment (JRE) be installed.

The Java 9 JRE will not work with the installer at this time.

To compile with Java 9, use the development version of Ptolemy II


This page covers installing Ptolemy II via a traditional Windows Installer

Other formats include: